$re = '/(?<=\()(.*), .*, .*\d+, \d{4}(?=\))/mi';
$str = 'Yuta Taki (滝 裕太, Taki Yuta, born August 29, 1999) is a Japanese football player.
Yuta Taki (John Smith, Taki Yuta, born August 29, 1999) is a Japanese football player.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);