package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([-+])?[.,]\b(\d+)(?:[Ee]([+-])?(\d+)?)?\b)|(?:([+-])?\b(\d+)(?:[.,]?(\d+))?(?:[Ee]([+-])?(\d+)?)?\b)`)
var str = `+452.4825E-2
+.0154E-45`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}