re = /(([-+])?[.,]\b(\d+)(?:[Ee]([+-])?(\d+)?)?\b)|(?:([+-])?\b(\d+)(?:[.,]?(\d+))?(?:[Ee]([+-])?(\d+)?)?\b)/m
str = '+452.4825E-2
+.0154E-45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end