import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([-+])?[.,]\\b(\\d+)(?:[Ee]([+-])?(\\d+)?)?\\b)|(?:([+-])?\\b(\\d+)(?:[.,]?(\\d+))?(?:[Ee]([+-])?(\\d+)?)?\\b)";
final String string = "+452.4825E-2\n"
+ "+.0154E-45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}