const regex = /^(([a-z0-9-_]{0,})\.){0,1}([a-z0-9-_]{1,})\.[a-z]{2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(([a-z0-9-_]{0,})\\.){0,1}([a-z0-9-_]{1,})\\.[a-z]{2,}$', 'gm')
const str = `test@test.aaaa
domaine_invalide.test
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}