using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<em>).*?(?=<\/em>)";
string input = @"<em>Something bold</em> some more text <em>another bit of bold</em>
<em>Something bold</em> some more text <em>another bit of bold</em>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}