re = /(?<=<em>).*?(?=<\/em>)/m
str = '<em>Something bold</em> some more text <em>another bit of bold</em>
<em>Something bold</em> some more text <em>another bit of bold</em>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end