$re = '/(?<=<em>).*?(?=<\/em>)/m';
$str = '<em>Something bold</em> some more text <em>another bit of bold</em>
<em>Something bold</em> some more text <em>another bit of bold</em>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);