package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((a=[^\s]*?\&)|(e=[^\s]*?\&)|(c=[^\s]*?\&))`)
var str = `test.com/?a=234&b=123&c=123&`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}