$re = '/((a=[^\s]*?\&)|(e=[^\s]*?\&)|(c=[^\s]*?\&))/';
$str = 'test.com/?a=234&b=123&c=123&';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);