// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((a=[^\s]*?\&)|(e=[^\s]*?\&)|(c=[^\s]*?\&))").unwrap();
let string = "test.com/?a=234&b=123&c=123&";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}