use strict;
my $str = 'аываыва <img sdasd asd > sdf dsf < sdf imG>
<h2>
< H2 sdf > </h2> sdf sdf sdf sdfsdf sdf sd f
< sdf sdf H2 sdf >
</h2>
< h2> adasd asd < h2>
< / H2>
<img 2>
<figure><img></figure> ыва ыва ыва ыва ыва ыва
< figure >< img >< / figure >
< figure sdfsdfsdfsd f> asd as das asd< img asd asd a/> asd asd asd <> < / figure> фываы ва ыв
<img>
< figure > фыв ыфв фыв фыв ыфв < img > < / figure >
<figure itemprop="associatedMedia image" itemscope="" itemtype="https://schema.org/ImageObject"> <meta itemprop="representativeOfPage" content="true"> <img itemprop="contentUrl url" src="//site.com/url.jpg" title="" alt=""> <meta itemprop="name" content=""> <meta itemprop="width" content=""> <meta itemprop="height" content=""></figure>';
my $regex = qr/(<[\s]*(?![\/])figure.*?>)|(([^<.*figure.*>\w])(<[\s]*(?![\/])img.*?>)([^<.*\/*figure.*>]))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}