re = /(<[\s]*(?![\/])figure.*?>)|(([^<.*figure.*>\w])(<[\s]*(?![\/])img.*?>)([^<.*\/*figure.*>]))/mi
str = 'аываыва <img sdasd asd > sdf dsf < sdf imG>
<h2>
< H2 sdf > </h2> sdf sdf sdf sdfsdf sdf sd f
< sdf sdf H2 sdf >
</h2>
< h2> adasd asd < h2>
< / H2>
<img 2>
<figure><img></figure> ыва ыва ыва ыва ыва ыва
< figure >< img >< / figure >
< figure sdfsdfsdfsd f> asd as das asd< img asd asd a/> asd asd asd <> < / figure> фываы ва ыв
<img>
< figure > фыв ыфв фыв фыв ыфв < img > < / figure >
<figure itemprop="associatedMedia image" itemscope="" itemtype="https://schema.org/ImageObject"> <meta itemprop="representativeOfPage" content="true"> <img itemprop="contentUrl url" src="//site.com/url.jpg" title="" alt=""> <meta itemprop="name" content=""> <meta itemprop="width" content=""> <meta itemprop="height" content=""></figure>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end