# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<[\s]*(?![\/])figure.*?>)|(([^<.*figure.*>\w])(<[\s]*(?![\/])img.*?>)([^<.*\/*figure.*>]))"
test_str = ("аываыва <img sdasd asd > sdf dsf < sdf imG>\n\n"
"<h2>\n\n"
"< H2 sdf > </h2> sdf sdf sdf sdfsdf sdf sd f\n\n"
"< sdf sdf H2 sdf > \n\n"
"</h2>\n"
"< h2> adasd asd < h2> \n"
"< / H2>\n\n\n"
"<img 2>\n\n"
"<figure><img></figure> ыва ыва ыва ыва ыва ыва\n\n"
"< figure >< img >< / figure >\n\n"
"< figure sdfsdfsdfsd f> asd as das asd< img asd asd a/> asd asd asd <> < / figure> фываы ва ыв\n\n\n"
"<img>\n\n"
"< figure > фыв ыфв фыв фыв ыфв < img > < / figure >\n\n"
"<figure itemprop=\"associatedMedia image\" itemscope=\"\" itemtype=\"https://schema.org/ImageObject\"> <meta itemprop=\"representativeOfPage\" content=\"true\"> <img itemprop=\"contentUrl url\" src=\"//site.com/url.jpg\" title=\"\" alt=\"\"> <meta itemprop=\"name\" content=\"\"> <meta itemprop=\"width\" content=\"\"> <meta itemprop=\"height\" content=\"\"></figure>")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.