using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""id"":([0-9]*)";
string input = @"{""id"":1145585,""label"":""1145585: Project Z""}
{""id"":1150322,""label"":""1150322: Project Waka 1""}|{""id"":1150365,""label"":""1150365: Project Waka 2""}
{""id"":1149240,""label"":""1149240: Analysis of Technical Options""}|{""id"":1149258,""label"":""1149258: Check and Report""}
{""id"":1148925,""label"":""1148925: Change Management Review""}|{""id"":1148920,""label"":""1148920: Follow-Up Meetings""}|{""id"":1148923,""label"":""1148923: Launch Date Definition""}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}