import re
regex = re.compile(r"\"id\":([0-9]*)", flags=re.MULTILINE)
test_str = ("{\"id\":1145585,\"label\":\"1145585: Project Z\"}\n"
"{\"id\":1150322,\"label\":\"1150322: Project Waka 1\"}|{\"id\":1150365,\"label\":\"1150365: Project Waka 2\"}\n"
"{\"id\":1149240,\"label\":\"1149240: Analysis of Technical Options\"}|{\"id\":1149258,\"label\":\"1149258: Check and Report\"}\n"
"{\"id\":1148925,\"label\":\"1148925: Change Management Review\"}|{\"id\":1148920,\"label\":\"1148920: Follow-Up Meetings\"}|{\"id\":1148923,\"label\":\"1148923: Launch Date Definition\"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")