// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"id":([0-9]*)"#).unwrap();
let string = "{\"id\":1145585,\"label\":\"1145585: Project Z\"}
{\"id\":1150322,\"label\":\"1150322: Project Waka 1\"}|{\"id\":1150365,\"label\":\"1150365: Project Waka 2\"}
{\"id\":1149240,\"label\":\"1149240: Analysis of Technical Options\"}|{\"id\":1149258,\"label\":\"1149258: Check and Report\"}
{\"id\":1148925,\"label\":\"1148925: Change Management Review\"}|{\"id\":1148920,\"label\":\"1148920: Follow-Up Meetings\"}|{\"id\":1148923,\"label\":\"1148923: Launch Date Definition\"}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}