#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.{12}$)[0-9a-zA-Z]*\s*$"
Local $sString = "abC123def456" & @CRLF & _
"abc123dEf45 " & @CRLF & _
"abc123def4 " & @CRLF & _
"sd45f45FFFRd" & @CRLF & _
"" & @CRLF & _
" abc123def45" & @CRLF & _
"abc123 ef456" & @CRLF & _
"123" & @CRLF & _
"sd45f45FFFR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")