import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.{12}$)[0-9a-zA-Z]*\\s*$";
final String string = "abC123def456\n"
+ "abc123dEf45 \n"
+ "abc123def4 \n"
+ "sd45f45FFFRd\n\n"
+ " abc123def45\n"
+ "abc123 ef456\n"
+ "123\n"
+ "sd45f45FFFR";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}