using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9 ‘’`',:/\\-]*$";
string input = @"mayank
mayank She,nkar
mayank S'hankar
Mayank S`hankar
mayank S‘hankar
mayank S’hankar
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}