re = /^[a-zA-Z0-9 ‘’`',:\/\\-]*$/m
str = 'mayank
mayank She,nkar
mayank S\'hankar
Mayank S`hankar
mayank S‘hankar
mayank S’hankar
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end