// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-zA-Z0-9 ‘’`',:/\\-]*$").unwrap();
let string = "mayank
mayank She,nkar
mayank S'hankar
Mayank S`hankar
mayank S‘hankar
mayank S’hankar
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}