re = /(?:C(?(3)(?(2)(?(1)(?!)|())|())|())|T(?(5)(?(4)(?!)|())|())){5}/m
str = 'TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TGATGCCGTCCCCTCAACTTGAGTGCTCCTAATGCGTTGC
TCCCC
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end