using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[а-яёіА-Я])o|o(?=[а-яёіА-Я])|(?<=\s)o(?=\s)";
string substitution = @"о";
string input = @"Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}