$re = '/(?<=[а-яёіА-Я])o|o(?=[а-яёіА-Я])|(?<=\s)o(?=\s)/m';
$str = 'Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах';
$subst = "о";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;