const regex = /(?<=[а-яёіА-Я])o|o(?=[а-яёіА-Я])|(?<=\s)o(?=\s)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[а-яёіА-Я])o|o(?=[а-яёіА-Я])|(?<=\\s)o(?=\\s)', 'gm')
const str = `Пpи прямoй ингаляции маслa вдыхаютcя из флакона, или c салфетки, нa которую наносят несколькo капель. Этoт спосoб даeт болеe сильный эффект, чeм аромакурительница.
слова o словах`;
const subst = `о`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);