package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.*)\s(.*)\s(.*)\s(.*)\s(.*)\s"(.*)"\s"(.*)"`)
var str = `word1 word2 word3 word4 word5 "word6" "word7"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}