re = /(.*)\s(.*)\s(.*)\s(.*)\s(.*)\s"(.*)"\s"(.*)"/
str = 'word1 word2 word3 word4 word5 "word6" "word7"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end