#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)text2(?=(?:.*?(text2))*)"
Local $sString = "text3 text3 text3 text3 text3 text3" & @CRLF & _
"" & @CRLF & _
"text1 text2 text1 text2 text1 text2" & @CRLF & _
"" & @CRLF & _
"text1 text2 text1 text2 text1 text2" & @CRLF & _
"" & @CRLF & _
"text1 text2 text1 text2 text1 text2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")