import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "text2(?=(?:.*?(text2))*)";
final String string = "text3 text3 text3 text3 text3 text3\n\n"
+ "text1 text2 text1 text2 text1 text2\n\n"
+ "text1 text2 text1 text2 text1 text2\n\n"
+ "text1 text2 text1 text2 text1 text2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}