import Foundation
let pattern = #"text2(?=(?:.*?(text2))*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
text3 text3 text3 text3 text3 text3
text1 text2 text1 text2 text1 text2
text1 text2 text1 text2 text1 text2
text1 text2 text1 text2 text1 text2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}