#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(((([0][1-9]|1\d)|2[0-9])|(([12]\d|0[1-9])|(3[01]))(?!\.02))\.(0[1-9]|1[0-2])\.(\d{4}|\d{2}))" & @CRLF & _
"|" & @CRLF & _
"((0(1|[3-9])|1[0-2])\.(0[1-9]|[12]\d|3[01])|02\.([1-9]|[12]\d))\.(\d{4}|\d{2})"
Local $sString = "Ftet30.02.1999" & @CRLF & _
"29.02.1999" & @CRLF & _
"28.03.1999" & @CRLF & _
"01.02.1999" & @CRLF & _
"29.00.1123" & @CRLF & _
"00.00.1999" & @CRLF & _
"01.01.11_+L12.22.2121" & @CRLF & _
"02.28.1111" & @CRLF & _
"01.12" & @CRLF & _
"09.18.1r11.30.67" & @CRLF & _
"" & @CRLF & _
"Ftet30.02.1999" & @CRLF & _
"" & @CRLF & _
"01.01.11_+L12.22.2121" & @CRLF & _
"02.30.11" & @CRLF & _
"03.30.11" & @CRLF & _
"02.29.11" & @CRLF & _
"02.30.12" & @CRLF & _
"02.10.12" & @CRLF & _
"" & @CRLF & _
"09.18.1r11.30.67" & @CRLF & _
"" & @CRLF & _
"Ftet30.02.1999" & @CRLF & _
"" & @CRLF & _
"01.01.11_+L12.22.2121" & @CRLF & _
"" & @CRLF & _
"09.18.1r11.30.67"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")