import re
regex = re.compile(r"""
(((([0][1-9]|1\d)|2[0-9])|(([12]\d|0[1-9])|(3[01]))(?!\.02))\.(0[1-9]|1[0-2])\.(\d{4}|\d{2}))
|
((0(1|[3-9])|1[0-2])\.(0[1-9]|[12]\d|3[01])|02\.([1-9]|[12]\d))\.(\d{4}|\d{2})
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("Ftet30.02.1999\n"
"29.02.1999\n"
"28.03.1999\n"
"01.02.1999\n"
"29.00.1123\n"
"00.00.1999\n"
"01.01.11_+L12.22.2121\n"
"02.28.1111\n"
"01.12\n"
"09.18.1r11.30.67\n\n"
"Ftet30.02.1999\n\n"
"01.01.11_+L12.22.2121\n"
"02.30.11\n"
"03.30.11\n"
"02.29.11\n"
"02.30.12\n"
"02.10.12\n\n"
"09.18.1r11.30.67\n\n"
"Ftet30.02.1999\n\n"
"01.01.11_+L12.22.2121\n\n"
"09.18.1r11.30.67")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")