using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((([0][1-9]|1\d)|2[0-9])|(([12]\d|0[1-9])|(3[01]))(?!\.02))\.(0[1-9]|1[0-2])\.(\d{4}|\d{2}))
|
((0(1|[3-9])|1[0-2])\.(0[1-9]|[12]\d|3[01])|02\.([1-9]|[12]\d))\.(\d{4}|\d{2})";
string input = @"Ftet30.02.1999
29.02.1999
28.03.1999
01.02.1999
29.00.1123
00.00.1999
01.01.11_+L12.22.2121
02.28.1111
01.12
09.18.1r11.30.67
Ftet30.02.1999
01.01.11_+L12.22.2121
02.30.11
03.30.11
02.29.11
02.30.12
02.10.12
09.18.1r11.30.67
Ftet30.02.1999
01.01.11_+L12.22.2121
09.18.1r11.30.67";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}