package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+\s+-[^-]*`)
var str = `"Option 01 - Random phrase - Top Menu
"Option 02 - Another Random Phrase - Su Menu
"Option 03 - More 01 Phrase - Menu
"Option 04 - More Phrase -
"Option 05 - Simple Phrase`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}