re = /\d+\s+-[^-]*/m
str = '"Option 01 - Random phrase - Top Menu
"Option 02 - Another Random Phrase - Su Menu
"Option 03 - More 01 Phrase - Menu
"Option 04 - More Phrase -
"Option 05 - Simple Phrase'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end