#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?!TSPU\b)[A-Z]{4,}(?:(?:\s+\w\.)?\s+\w+)?"
Local $sString = "JINA L. CHOI (NY Bar No. 2699718)" & @CRLF & _
"" & @CRLF & _
"ERIN E. SCHNEIDER (Cal. Bar No. 216114) schneidere@sec.gov" & @CRLF & _
"" & @CRLF & _
"MONIQUE C. WINKLER (Cal. Bar No. 213031) winklerm@sec.gov" & @CRLF & _
"" & @CRLF & _
"JASON M. HABERMEYER (Cal. Bar No. 226607) habermeyerj@sec.gov" & @CRLF & _
"" & @CRLF & _
"MARC D. KATZ (Cal. Bar No. 189534) katzma@sec.gov" & @CRLF & _
"" & @CRLF & _
"JESSICA W. CHAN (Cal. Bar No. 247669) chanjes@sec.gov" & @CRLF & _
"" & @CRLF & _
"RAHUL KOLHATKAR (Cal. Bar No. 261781) kolhatkarr@sec.gov" & @CRLF & _
"" & @CRLF & _
"The Investor Solicitation Process Generally Included a Face-to-Face Meeting, a Technology Demonstration, and a Binder of Materials [...]" & @CRLF & _
"TSPU or taken" & @CRLF & _
"TSPU or the" & @CRLF & _
"TSPU only" & @CRLF & _
"TSPU was" & @CRLF & _
"TSPU and"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")