# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b(?!TSPU\b)[A-Z]{4,}(?:(?:\s+\w\.)?\s+\w+)?"
test_str = ("JINA L. CHOI (NY Bar No. 2699718)\n\n"
"ERIN E. SCHNEIDER (Cal. Bar No. 216114) schneidere@sec.gov\n\n"
"MONIQUE C. WINKLER (Cal. Bar No. 213031) winklerm@sec.gov\n\n"
"JASON M. HABERMEYER (Cal. Bar No. 226607) habermeyerj@sec.gov\n\n"
"MARC D. KATZ (Cal. Bar No. 189534) katzma@sec.gov\n\n"
"JESSICA W. CHAN (Cal. Bar No. 247669) chanjes@sec.gov\n\n"
"RAHUL KOLHATKAR (Cal. Bar No. 261781) kolhatkarr@sec.gov\n\n"
"The Investor Solicitation Process Generally Included a Face-to-Face Meeting, a Technology Demonstration, and a Binder of Materials [...]\n"
"TSPU or taken\n"
"TSPU or the\n"
"TSPU only\n"
"TSPU was\n"
"TSPU and")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.