import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?!TSPU\\b)[A-Z]{4,}(?:(?:\\s+\\w\\.)?\\s+\\w+)?";
final String string = "JINA L. CHOI (NY Bar No. 2699718)\n\n"
+ "ERIN E. SCHNEIDER (Cal. Bar No. 216114) schneidere@sec.gov\n\n"
+ "MONIQUE C. WINKLER (Cal. Bar No. 213031) winklerm@sec.gov\n\n"
+ "JASON M. HABERMEYER (Cal. Bar No. 226607) habermeyerj@sec.gov\n\n"
+ "MARC D. KATZ (Cal. Bar No. 189534) katzma@sec.gov\n\n"
+ "JESSICA W. CHAN (Cal. Bar No. 247669) chanjes@sec.gov\n\n"
+ "RAHUL KOLHATKAR (Cal. Bar No. 261781) kolhatkarr@sec.gov\n\n"
+ "The Investor Solicitation Process Generally Included a Face-to-Face Meeting, a Technology Demonstration, and a Binder of Materials [...]\n"
+ "TSPU or taken\n"
+ "TSPU or the\n"
+ "TSPU only\n"
+ "TSPU was\n"
+ "TSPU and";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}