package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^=\s]+)\s*=\s*("[^"]+"|[^#]+?)\s*(?:$|#)`)
var str = `foo = "/usr/local/bin" # path string
eggs = [0, 1, 2, 3, 1]
spam = True # boolean
bar = 42
test = "this will be a big #fail"
path = "/home/tmp/valid#file#name" # comment`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}