re = /([^=\s]+)\s*=\s*("[^"]+"|[^#]+?)\s*(?:$|#)/m
str = 'foo = "/usr/local/bin" # path string
eggs = [0, 1, 2, 3, 1]
spam = True # boolean
bar = 42
test = "this will be a big #fail"
path = "/home/tmp/valid#file#name" # comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end