package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)bar(bar)`)
var str = `foobarbarfoo`
var substitution = "<NA>\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}