import Foundation
let pattern = #"bar(bar)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"foobarbarfoo"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<NA>\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)