use strict;
my $str = 'foobarbarfoo';
my $regex = qr`bar(bar)`mp;
my $subst = '<NA>\\1';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";