using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"regex|cheat|sheet";
string input = @"https://techearl.com/regex-cheat-sheet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}