package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)regex|cheat|sheet`)
var str = `https://techearl.com/regex-cheat-sheet`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}