$re = '/regex|cheat|sheet/m';
$str = 'https://techearl.com/regex-cheat-sheet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);