package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[^\W0-9]*[0-9]\w*\b`)
var str = `70053105P
A1A1A1A1A1... etc., but not AAAAAAAA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}