re = /\b[^\W0-9]*[0-9]\w*\b/m
str = '70053105P
A1A1A1A1A1... etc., but not AAAAAAAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end