$re = '/\b[^\W0-9]*[0-9]\w*\b/m';
$str = '70053105P
A1A1A1A1A1... etc., but not AAAAAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);